UltraMixer - Java powered UltraMixer needs Java version 1.6 or higher. We recommand to use the lastest Java runtime environment (JRE) version 1.8 for Windows and Linux and Java version 1.6 for Mac OS X. If you don’t already have Java installed on your system, please do the following: a) On Windows: Install UltraMixer incl. Java (33 MB). b) On Mac OS X: Get Java for Mac OS X from Apple. c) On Linux: Get Java from SUN.